StarCraft2 Map Editor

提供: StarCraft II: Legacy of the Void 日本語Wiki
移動: 案内検索

StarCraft2にはマップ・エディターが付属していますので、誰でもオリジナルのマップを作ることが出来ます。
作業の流れとしては、地形を作る>資源とスタート地点を配置>テストプレイ>一般公開となります。

マップ制作のチュートリアル

まず、非常に簡単な対戦マップを作ってみましょう。
まず、スタート時のウインドウで[エディターを起動]を押します。
Editor01.png

起動すると上に沢山のボタンが並んでいますが、主に使うものだけを説明します。
Editor02.png
1 - [Terrain]  地形の高低差を作ったり地面の模様などを設定します。
2 - [Units]   ユニットや資源を配置します。
3 - [Doodads]  木や建物など装飾品を配置します。
4 - [Points]   スタート地点などを設定します。

5 - [Translation] オブジェクトを移動します。
6 - [Rotation]   オブジェクトを回転させます。
7 - [Scale]    オブジェクトの大きさを変えます。

Editor03.png
[Terrain]レイヤーに切り替え、[Cliff]ボタンを押してマウスで自由に描いて、ベースになる部分の地形を1段上げます。
もちろん平らのままでも良いですが地形説明のため上げてます。この辺はお好みで。

プレイ可能なエリアは青い枠線で表示されますが、現れていない場合はアルファベットのOキーを押して表示させてください。
ちなみに、黄色い点線はカメラ視点の移動可能エリアです。また、Gキーを押すとグリッドを表示できます。

視点の移動やズームはゲーム中と同じ操作で行なえますが、その他にも
Controlキー+マウス中央ボタンで高度方向の移動、Altキー+マウス中央ボタンで回転させることも可能です。
また、マウス中央ボタンをダブルクリックするとゲーム視点にリセットします。

Editor22.png
地面を下げるツールや、その高さのまま面積を広げるツールもありますので試してみると良いでしょう。
ブラシの大きさはスライダーで調整出来ますし、ブラシ形状も●■◆が選べます。

Editor04.png
Add Lampボタンで崖の上をクリックし、スロープを作ります。

Editor05.png
[Points]レイヤーに切り替え、[Start Location]でそれぞれのベースのスタート位置をクリックして設定します。

Editor06.png
[Units]レイヤーに切り替え、(Object Type)をResourcesにしてミネラル8個とガス2個を配置します。
ちなみに、キーボードのスペースバーを押すとカーソルが選択モードに変わり、位置の微調整が出来ます。

Editor29.png
★ヒント  Shift+Hキーを押してPathingレイヤーを表示させると、
ミネラルやガスの周りにある基地が建てられないエリアが分かるので、位置の微調整が楽になります。
もう一度Shift+Hキーを押すと非表示になります。(日本語入力モードでは反応しませんので注意)


Editor07.png
ミネラルとガスを反対側の陣地に180度回転コピーして使用することにしましょう。
ミネラルとガスをすべてドラッグして選択し、EditメニューからCopyを選んでコピーしてください。

上にある[Rotation]ボタンを押し、
EditメニューでPasteを選んでから Rotate>180°を選んで配置したい場所をクリックすれば、
反対側のミネラルとガスを配置できます。 これで完了です。初めてのマップが完成しました!

ちなみに、Flip>Horizontallyで水平反転、Verticallyで垂直反転も出来ますし、
地形もグリッド単位でドラッグ選択して、コピー&ペーストが可能です。
またドラッグ選択は、Control+Dキーで斜めモードに切替可能です。

Editor08.png
ローカルでテストするために、片方のプレイヤーをコンピュータに設定しましょう。
Mapメニューから[Player Properties]を出し、Player2をComputerに変更してください。

Editor09.png
右上にある[TestDocument]ボタンを押すとStarCraft2が起動し、テストプレイが可能です。

Editor10.png
何度かテストしてみてゲームバランスを調整して、プレイしたくなるような地形を考えてみましょう。
ゲームを面白くするためXel'naga Towerや、壊せる岩、崩れて塞ぐ岩などを配置したり、
[Doodads]レイヤーで木や建物など装飾品を置いてマップを飾ってみるのも良いでしょう。

ちなみに、壊せる岩は[Units]レイヤーのプルダウンメニュー[Destructible]の中にあります。
崩れて塞ぐ岩の名前は"Rock Tower""Cooling Tower"で検索すると出てきます。
("Rock Tower""Cooling Tower"だけは、コピーして増やすと正常に動作しなくなりますのでご注意ください。)
視界を遮るオブジェクトが欲しい場合は、[Doodads]レイヤーに切り替えて"LOS BLOCKER"で検索すると出てきます。


サーバーにアップロードする

Editor11.png
満足行く出来のマップが出来たら、Blizzardのサーバーにアップロードしましょう。
もう一度Mapメニューから[Player Properties]を出し、Player2をUserに変更します。

Editor12.png
Mapメニューから[Map Info...]を選び、名前と説明文を変更してください。
(これらがデフォルトのままではアップロードできません)
[OK]ボタンを押し、いったんファイルを保存してください。

Editor13.png
Fileメニューから[Publish]を選びます。
[Log in…]ボタンを押して、Blizzard登録のIDとパスワードでログインして[Next]を押してください。

Editor14.png
Revisionは、バージョンナンバーの設定です。
小変更の場合は[Minor]、大きな変更があった場合は[Major]を選ぶといいでしょう。
アップロードするたびに、バージョンナンバーに0.1あるいは1が足されます。

自分だけで楽しむ場合は[Private]、一般公開する場合は[Public]を選んでください。
[Locked]を選び確認画面で[はい]を押して、[Next]を押してください。
(まだ問題がある場合は、下の方に茶色い字で[ファイルを保存してください]とか
[名前を変えてください]などの意味の英文が出ますので、確認して対処してください。)

Editor15.png
[OK]を押すと、マップファイルのアップロードが始まります。
初めてアップする場合は、Blizzardの規約画面が出ますので承諾にチェックが必要です。
Completeの数字が[100%]になって、音が鳴ったらアップロード完了です。
もし、アップロードが途中で止まってしまった場合は、エディターを再起動すればアップロードできます。

Editor16.png
StarCraft2を起動して[CUSTOM]の[MELEE]を選び、
プルダウンメニューで[My Published]を選ぶと先程アップしたマップがあるはずです。
これで通常のマップと同じようにプレイできるようになりました。


Editor23.png
マップが不要になった場合、Fileメニューの[Manage Published...]を選んで、
リストからマップを選び[Remove From Account]ボタンを押すとサーバーから削除できます。

Editor43.png
Mapメニューの[Battle.net info...]では複数のキャプチャー画像が登録できます。
これはゲーム中のマップ選択画面でスライドショーとして表示されます。
一番上はマップ全体のレイアウトが分かる画像にしてください。
リストを選択して上下の矢印ボタンを押すと、表示される順番を変える事も出来ます。


[Terrain]レイヤーで地形を作る

[Terrain]レイヤーの詳しい説明です。

NEWで新規マップを作ると、ゲームタイプの選択などの後にこのようなウインドウが出ます。
Editor17.png
Width:Heightは作るマップの広さで、プルダウンにより変更が可能です。
ちなみに、マップを作った後でもMapメニュー>Map Bounds...で面積の変更が出来ます。

Texture Setは地面の模様のセットのことで、ジャングルや溶岩地帯、
宇宙に浮かぶプラットフォームなどをテーマにしたテクスチャーセットが用意されています。
なお、最初に選ぶ[Wings of Liberty][Heart of the Swarm][Legacy of the Void]の種類の違いで、
それぞれのバージョンにしか無い特有のテクスチャーセットがある場合もあります。

Editor18.png
[Terrain]レイヤーでTextureのブラシツールを選ぶと、パレットで選んだテクスチャーで地面を自由に塗ることが出来ます。
それぞれのブラシの説明は以下の通りです。
Editor33.png
しかし実際のところ、地面の一部の色だけブラシで変えることはあまりしないと思われます。

Editor19.png
そこで右端にあるバケツツールで、同じ高さを一気に塗ることをオススメします。
(プルダウンメニューはCliff Levelにしておいてください。)

Editor20.png
Heightツールでは、地面を持ち上げたり沈めたり出来ます。
しかし、ユニットは平らな地面と同じように苦も無く急坂を上ったり降りたりするため、
非常に不自然に見えてしまうので、実際にはこのツールを使うシーンは少ないと思われます。
急坂はSmoothを使うと自然に見えるように出来ます。

Editor21.png
Cliffツールは非常に良く使います。
2種類のボタンを切り替えると、崖の見た目が[自然の崖]や[人工的な崖]になります。

なお、[Add Lamp]ボタンでスロープを作った地形をコピー&ペーストすると、スロープに穴が空くバグがありますが、
[Add Lamp]で穴の空いたスロープをクリックするか、いったん消してもう一度作ると正常になります。

Editor27.png
Terrain Objectは、テクスチャーセットの種類によっては地面を飾るオブジェクトを置くことが出来ます。
しかし、オブジェクトが登録されていないテクスチャーセットも多く、リストに何も現れないこともあります。

Editor28.png
Waterツールではマップ上でグリッドを塗りつぶすと、様々な模様の水(あるいは溶けた溶岩)を配置することが出来ます。
デフォルトでは地面より高い位置に水が配置されるので、スライダーで高さを調整して下げてください。
一番下にある[Edit Water]ボタンを押すと非常に細かい設定も出来ますし、高さ調整も数値で入れることが出来て楽です。
なお、[Cliff]ツールで穴を作った場合はユニットは入れませんが、[Height]ツールで地面を下げた場合はユニットが通過できます。

Editor30.png
Texture Setツールは、MapメニューのMap Texture Sets...でテクスチャーセットを加えると
グリットごとに2つのテクスチャーセットを設定して使うことが出来るようですが、
非常に不自然に見えるので通常は使うことは無いと思われます。

Editor31.png
Roadツールでは、クリックした2点の間に道路が描かれます。沢山クリックするとカーブも描けます。
スペースバーでカーソルを変えると、それぞれのポイントを選択して位置や形の微調整が出来ます。
なお、テクスチャーセットにより道路のデザインが異なります。
また、[Doodads]レイヤーに切り替えて"Road"で検索すると、いくつかの道路の素材も見つけることが出来ます。

Editor32.png
Foliageツールは選択した部分に雑草を生やします。良く見ると風に揺れてユラユラ揺れているのが分かります。
デフォルトではマップのすべてが選択されていますので、[Generate Foliage]ボタンを押せばマップ全体に雑草が生えます。
生やしたくない部分がある場合は、隣りにある[Disallow Foliage]ボタンでその部分の選択を解除してからボタンを押してください。
雑草の多さはスライダーで調整出来ます。削除したい場合はスライダーを0位置にしてボタンを押せば削除されます。
なおテクスチャーの違いや塗った濃さ、またはテクスチャーセットにより雑草のデザインや生える頻度が異なり、
宇宙では小さなプレートや残骸が散りばめられます。

★ヒント  コンクリートなど草が生えそうもない地面にはボタンを押しても草が生えませんが、
土のテクスチャーで草を生やしてから、コンクリートのテクスチャーで塗りつぶすことで配置することが可能になります。

Editor34.png
Lightingツールについては良く分かりません。マップ上でドラッグするとミニマップにラインが現れますが効果は不明です。

  • コメントで教えていただきました。塗った箇所をDataやTriggerを使ってデフォルト以外の照明にカスタマイズすることができるツールらしいです。


Editor35.png
Creepツールは、描いた所にCreepが現れます。対戦マップでは通常は使うことはないでしょう。

Editor36.png
Visionツールで描くと、ユニットの視界を遮ることが出来ます。おそらくキャンペーンマップ用の機能だと思われます。

Editor37.png
Customツールについても良く分かりません。イベント発生場所を指定する物かもしれません。

  • こちらもコメントで教えていただきました。DataやTriggerを使ってイベントやギミックに使うことが出来て、キャンペーンやアーケードで使われるらしいです。



[Doodads]レイヤーでマップを飾る

[Doodads]レイヤーでは魅力的な装飾オブジェクトを好きなように配置出来ますが、
リストにあるオブジェクトがあまりにも多すぎる上に、どのように使うものなのか分からない物もあります。
そこで、公式マップをダウンロードして、気に入ったオブジェクトをコピーして使うと便利です。

Editor24.png
FileメニューでOpenを選び、Blizzardタブでログインしてお好みのマップを選んで開いてください。
(エディターは複数のマップを開くことが出来て、[Window]メニューからそれぞれを切り替えることが出来ます。)

Editor25.png
例えば、Old Estateと言うマップの崖下には驚くほど凝った町並みが作られていますが、
これらの一部を[Doodads]レイヤーで選択してコピーし、自分のマップに切り替えてペーストが可能です。

同様に、[Units] レイヤーにして公式マップのミネラルとガスもコピーして自分のマップにペーストして使えば、
ベースからの距離や位置などの微調整がいらなくなるので大変便利です。
なおリストに無いレアなオブジェクトも、公式マップには使われているようです。

もし、通常置けない位置にDoodadsオブジェクトを置きたい場合、
あるいは移動できない位置に移動したい場合は、Shiftキーを押しながら操作を行ってください。

Editor38.png
[Doodads]レイヤーでlightで検索すると色々なライトのオブジェクトがあり、
幻想的かつ効果的な演出が楽しめます。
もちろん[Rotation]ボタンで向きを変えたり、[Scale]ボタンで大きさも変えられます。
なおゲームのグラフィックレベルを下げている場合は、この効果を見ることは出来ません。

Editor39.png
環境エミッターを置くことで、色々な天候を再現できます。
検索ボックスで"Rain"で検索してみてください。他にも"Smoke""Fog""Snow""Wind"など色々な環境エミッターがあります。


[Pathing]レイヤーで移動制限をする

[Pathing]レイヤーではユニットが入れないエリアを指定することが出来ます。
Editor44.png
このツールは、おもに建物や湖などを配置した時にユニットが素通りしてしまうのを防ぐために使います。

Editor45.png
制限を描く(Painted Pathing)では、マウスで自由に行動制限地帯を描くことが出来ます。
Shift+Hキーを押すと、Pathingレイヤーを表示/非表示にすることが出来ます。
全許可(Ground)は、崖などに指定すると平らな地面と同じように通過可能になりますが、通常は使うことはないでしょう。
崖風にブロック(Cliff Bloking)は、通常の陸上ユニットは入れませんがColossusは入れます。(なぜかReaperは入れません)

飛行制限ポイントを置く(No Fly Zones)は、高いビルなどに使い空中ユニットが素通りしないようにします。
なお飛行制限区域は円形固定で、ペイントで形状を描くことは出来ません。
Editor46.png
円形のマークは空中に置かれていますので斜めから見る視点だと正確な位置が分かりませんので、
Altキー+マウス中央ボタンで上からの視点にしてから、位置を微調整することをオススメします。
制限の大きさは、ダブルクリックするかエンターキーを押すと現れるウインドウ内の数値で調整出来ます。


多人数プレイのマップを作る

Editor41.png
4人用マップを作る場合は、[Points]レイヤーの[Start Location]でスタート位置を4箇所クリックして設定したら、
Mapメニューの[Player Properties]を出し、Player1~4のControlを[User]に変更します。
(Shiftキーで複数選択して一括で変更できます。)

Editor40.png
2対2のチーム戦のマップにする場合は、Team Placement(Basic)タブでチーム分けを4人分行ってください。
2v2用のBlizzard公式マップをダウンロードして、4つのStart Locationのリストをそれぞれクリックして、
どこにチェックが入っているか調べてみると分かりやすいと思います。

Editor42.png
Team Placement(Advanced)タブでは、更に複雑なチーム分けの設定が行なえます。
例えば、4対4のチーム戦のマップに1対1、2対2、3対3の時の設定も加えておきたい場合は、
[New...]ボタンを押して新しいチーム設定を作り、1対1、2対2、3対3それぞれの設定を行ってください。
これも4v4用のBlizzard公式マップを調べてみると分かると思います。


リンク





コメント

グッジョブです!自分もSC2エディター使いです!
Heightツールは後から一番右のSmoothを使用すると自然に見えるようにできますよ。
Lightingツールは塗った箇所をDataやTriggerを使ってデフォルト以外の照明にカスタマイズすることができます。
CustomツールはRegionツールと似てて、これもDataやTriggerを使ってイベントやギミックに使うことができます。主にキャンペーンやアーケードで使われてます。
もっと日本人ユーザーが増えたらいいですね!
-- Tk (トーク) 2018年3月15日 (木) 02:45 (JST)

どうもありがとうございます。(^ω^)
私もまだ初心者なんですがマップ作りが非常に楽しいので、ゲームそっちのけでマップづくりにハマっています。(笑)
記事で気になった部分があったら、自由に編集してOKなのでよろしくお願いします。
ちなみに、以下は私が作ったマップです。南北アメリカに切り替えて検索すると出てきますので遊んでみてくださいね。
Diamond Station
City of Enceladus
Riverside base (Rainy Day)
Mineral Freighters Space Port
Scrap station 4v4
Char Neuron

-- Sekiai (トーク) 2018年3月19日 (月) 10:08 (JST)